Get the latest live chat benchmark data broken down by team size & industry

Read more
Why can’t my visitors see the Chat Button on my website

This article will detail the possible causes of chat button display issues and suggest possible solutions to fix the issue.

Issue

  1. All my website visitors can’t see the chat button on my website.
  2. A portion of website visitors can’t see the chat button on my website.

Cause

  1. There is an issue with how your Live Chat JavaScript Installation has been pasted into your website code.
  2. The visitor reporting this error has been banned.
  3. Chat Button is set to be visible only on certain Domain/URL in Campaign> Chat Button> Advanced.
  4. There are no agents online and the Hide offline Button option is enabled.
  5. Chat button is hidden by some rules implemented on your website.

Solution

  1. Make sure your live chat code is pasted in-full within your website code. You can find the correct installation code from the Control Panel Installation > Live Chat Code.
  2. Check your Ban List under Settings > Ban. If the visitor reporting the issue has their IP address listed there, they will be unable to see the chat button. You can lift the ban by deleting their IP from the ban list. If their IP is not there, ask the visitor to clear their browser cookies.
  3. Uncheck Display my chat button on specified domains/URLs only from Campaign> Chat Window> Advanced.
  4. If you want there to be a live chat button on your website even when your agents are offline, keep the Hide Offline button option unchecked from Campaign> Chat Button> Advanced.
  5. Ensure that there are no rules on your website that are overriding the visibility of the Chat Button.